Parser Error: Could not load type…

Problem

An error occurred during the parsing of a resource required to service this request, e.g.:

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load type 'XXXX’.

This typically means that you do not have a Virtual Directory set up for your application.  It can also occur when an application has not been successfully compiled.

Solution

Step 1:  See Creating a Virtual Directory for Your Application for detailed instructions on creating a virtual directory for your application.

Step 2:  Your application’s Bin folder is missing or the application’s DLL file is missing.  See Copying Your Application Files to a Production Server for detailed instructions.

Step 3:  You may have deployed to the webroot folder, but have not changed some of the settings in the Web.config file.  See Deploying to Webroot for detailed instructions.

Step 4:  Your application may not have successfully compiled because Visual Studio .NET is caching an old version of the BaseClasses.dll file.  See Error BC30002: Type ‘XXX’ is not defined… for details on how to get Visual Studio .NET to use the proper DLL files.

Migrating to Iron Speed Designer V3.2

In some cases, after migrating your application from an older version of Iron Speed Designer to a newer version, the following error message will be displayed when running your application.

Parser Error

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

 

Parser Error Message: Could not load type 'IronSpeed.Base.Web.UI.GenericPage'.

 

Source Error:

Line 1: <%@ Page Language="cs" AutoEventWireup="false" Inherits="IronSpeed.Base.Web.UI.GenericPage" %>

Line 2: <%@ Register Tagprefix="IronSpeed" Namespace="IronSpeed.Base.Web.UI.WebControls" Assembly="BaseClasses" %>

Line 3: <%@ Import NameSpace="IronSpeed.Base.Configuration" %>

 

Source File: C:\Inetpub\wwwroot\PeerReviewData\default.aspx Line: 1

This occurs because IronSpeed.Base was changed to BaseClasses.  In order to fix this problem, replace the three lines of code with these:

<%@ Page Language="vb" AutoEventWireup="false" Inherits="BaseClasses.Web.UI.GenericPage" %>

<%@ Register Tagprefix="BaseClasses" Namespace="BaseClasses.Web.UI.WebControls" Assembly="BaseClasses" %>

<%@ Import NameSpace="BaseClasses.Configuration" %>

See Also

Part VII:  Troubleshooting Applications

Application Won’t Run

Application Runs But No Data is Displayed

Application Error Messages